Uppdatering av Frisims HTTP-klient

Frisims klient för att hämta in webbsidor har uppdaterats. Anledningen till uppdateringar var problemen med t.ex Di.se:s komprimerade HTML.

Från att tidigare ha använt HTTPClient 0.3-3 så har istället Jakarta-versionen av koden installerats. Jakarta-versionen av koden kräver två stycken Jakarta commons-paket för att fungera, dels Logging för att kunna sköta felhantering, dels Codec för att klara komprimerad HTML.

Det är alltid lite kritiskt att göra uppdateringar i produktionsversionen av koden när det gäller så vitala delar som sidnedladdning då det är en hel del som kan gå fel. Jag kan bara hoppas att den nya modulen inte ska ställa till några problem i fortsättningen.

Comments are closed.